Apache APISIX存在改写 X-REAL-IP header 风险公告(CVE-2022-24112)

1#漏洞描述
在 Apache APISIX 2.12.1 之前的版本中(不包含 2.12.1 和 2.10.4),启用 Apache APISIX batch-requests 插件之后,会存在改写 X-REAL-IP header 风险。

该风险会导致以下两个问题:
  • 攻击者通过 batch-requests 插件绕过 Apache APISIX 数据面的 IP 限制。如绕过 IP 黑白名单限制。
  • 如果用户使用 Apache APISIX 默认配置(启用 Admin API ,使用默认 Admin Key 且没有额外分配管理端口),攻击者可以通过 batch-requests 插件调用 Admin API 。

2#影响版本
  • Apache APISIX 1.3 ~ 2.12.1 之间的所有版本(不包含 2.12.1 )
  • Apache APISIX 2.10.0 ~ 2.10.4 LTS 之间的所有版本 (不包含 2.10.4)
3#漏洞详情
漏洞优先级:高
漏洞公开时间:2022 年 2 月 11 日
漏洞详情:在受影响的 Apache APISIX 版本中,可以对 conf/config.yaml 和 conf/config-default.yaml 文件显式注释掉 batch-requests,并且重启 Apache APISIX 即可规避此次风险。
CVE 详细信息:https://nvd.nist.gov/vuln/detail/CVE-2022-24112
基础分数: 9.8 关键
Exp和Poc情况:团队成员发现完整Exp已经流出!!!


4#漏洞修复
该问题目前已在 2.12.1 和 2.10.4 版本中得到解决,请尽快更新至相关版本。

5#贡献者简介
该漏洞由 Sauercloud 上报给 Apache 软件基金会。感谢各位对 Apache APISIX 社区的贡献。
本博客所有文章如无特别注明均为原创。作者:渊龙Sec团队复制或转载请以超链接形式注明转自 渊龙Sec团队博客
原文地址《Apache APISIX存在改写 X-REAL-IP header 风险公告(CVE-2022-24112)
分享到:更多

相关推荐

发表评论

路人甲 表情
看不清楚?点图切换 Ctrl+Enter快速提交

网友评论(0)